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Error Code: 24FAE25D when connected to Live Published Data Source


Published: 09 Dec 2021
Last Modified Date: 10 Dec 2021

Issue

When connected to a Live Published Data Source in Tableau Desktop or Tableau Server, attempting to drag in new fields results in the following error:

The connection to the data source might have been lost.
Error Code: 24FAE25D
An error occurred while communicating with the data source
A table named "[sqlproxy].[Table_Name]" does not exist.
DataServiceFailure

This issue can occur when editing or creating a data source, and is reproduced under the following conditions:

1. An existing Extract is converted to Live in the Data Sources pane.
2. One or more tables in the Relationships pane from the existing Data Source is removed or replaced.
3. Data Source is Published to Tableau Server.
4. Users connect to the Published Data Source.
 

Environment

  • Tableau Desktop
  • Tableau Server
  • Live Published Data Sources

Resolution

  1. Download the Data Source from Tableau Server, (it should download as a TDSX)
  2. Open the TDSX file in Tableau Desktop.
  3. Create to a Local Copy of the Connection.
  4. Right-click the Local Connection > Extract > Remove 
  5. Select "Remove the extract and delete the extract file." and click OK.
  6. Republish the Data Source to Tableau Server.
This removes the reference to the non-existent extract.
 

Cause

Tableau Desktop is failing to remove the reference to the extract even after switching the connection to Live.
This issue is under investigation by the development.
 
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