KNOWLEDGE BASE

Error "Cannot evaluate user filter; no current user or group" When Refreshing Data Source With User Filter


Published: 17 Apr 2019
Last Modified Date: 20 Sep 2019

Issue

When refreshing a data source through Tableau Online that contains a user filer, the refresh will fail with the following error:

"Cannot evaluate user filter; no current user or group" when they contain user filters."

Environment

  • Tableau Online
  • Salesforce

Cause

This behavior is related to a known issue with ID 896306 which has been corrected in more recent releases.
Did this article resolve the issue?