KNOWLEDGE BASE

Error "Bad Connection: Tableau could not connect to the data source" When Running a Second Tableau Desktop Instance


Published: 31 May 2018
Last Modified Date: 15 Oct 2018

Issue

When trying to connect to a data source in a second session of Tableau 2018.1 (while another session is running), the following error message may occur:

An error occurred while communicating with Tableau Data Engine. Bad Connection: Tableau could not connect to the data source. There was problem and the data engine could not start properly.

Environment

  • Tableau Desktop 2018.1
  • Windows

Resolution

Work with your IT team to ensure that your computer is up to date with all Windows updates.

Cause

The necessary Windows Updates are not installed on the affected machine.

Additional Information

The information below is related to a third-party product. Please note that while we make every effort to keep references to third-party content accurate and up to date, the information we provide here might change without notice as the third-party product changes:
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