KNOWLEDGE BASE

Error "An error occurred while communicating with Amazon Athena. Invalid username or password." When Connecting to Amazon Athena


Published: 05 Jan 2018
Last Modified Date: 10 Jan 2020

Issue

When connecting to Amazon Athena from Tableau Desktop, the following error might occur:
 
An error occurred while communicating with Amazon Athena. Invalid username or password

throw DataSourceException (type=BadPassword): com.tableausoftware.jdbc.TableauJDBCException: Exception while connecting to server.
[Simba][JDBC](10100) Connection Refused: [Simba][JDBC](11640) Required Connection Key(s): AwsRegion, S3OutputLocation; [Simba][JDBC](11480) Optional Connection Key(s): AwsCredentialsProviderArguments, AwsCredentialsProviderClass, BinaryColumnLength, ComplexTypeColumnLength, ConnectTimeout, MaxCatalogNameLength, MaxColumnNameLength, MaxErrorRetry, MaxSchemaNameLength, MaxTableNameLength, ProxyHost, ProxyPort, ProxyPWD, ProxyUID, S3OutputEncOption, Schema, SocketTimeout, StringColumnLength, UseAwsLogger

There was a Java error.

Invalid username or password.

 
 

Environment

  • Tableau Desktop
  • Tableau Server
  • Amazon Athena

Resolution

 Amazon Athena JDBC driver to a previous version.

  1. Go to the "Using Athena with the Previous Version of the JDBC Driver" page on the Amazon website.
  2. Download AthenaJDBC41-2.0.7.jar driver. 
  3. Save the driver at the following locations:
Windows: Save the Amazon Athena JDBC jar in the C:\Program Files\Tableau\Drivers location.
Mac: Save the Amazon Athena JDBC jar in the ~/Library/Tableau/Drivers location.

Note: It is no longer possible to download the AthenaJDBC41-1.0.1.jar driver that originally was recommended.

Cause

The  Amazon Athena JDBC driver used has changed the connection string, preventing Tableau from making the connection to Amazon Athena.
Did this article resolve the issue?