KNOWLEDGE BASE

Error "548D1061" Occurs and Unable to Activate With LBLM in Tableau Desktop


Published: 30 Aug 2023
Last Modified Date: 04 Sep 2023

Issue

When using LBLM to activate Tableau Desktop, the below error occurs.
------------------------------------

An error occurred while communicating with the data source.

Error Code:548D1061
Unable to connect to Tableau Server.
Authorization request timed out. The user may have closed the browser or cancelled the request.

 

Environment

  • Tableau Desktop 2022.3
  • External browser used for sign-in
  • Windows
  • AWS EC2
  • LBLM

Cause

The firewall on the AWS EC2 environment blocked [redirect_uri=http://127.0.0.1] which was included in the URL sent from Tableau Desktop to complete LBLM.

Additional Information

When signing into Tableau Server or making LBLM activation, the below behavior was found.
1. With an external browser, [http://127.0.0.1] is included in the sign-in URL in the browser.
2. With an embedded browser, [http://127.0.0.1] is not included in the sign-in request.

Below is an example when signing into the Tableau server with an external browser
============
http://server.name/#/signin?client_type=desktop&externalRedirect=XXXcode_challenge=XXXredirect_uri=http://127.0.0.1:XXX...
============
Did this article resolve the issue?