KNOWLEDGE BASE

Error "(50363) Failed to get username. Unspecified GSS failure." When Trying to Test or Update Hadoop Hive Connection Using Kerberos on Tableau Server


Published: 22 Jun 2022
Last Modified Date: 24 Jun 2022

Issue

On Tableau Server, trying to test, edit or refresh the extract of a published Hortonworks Hadoop Hive data source connection using MIT Kerberos displays the following error:

There was an unknown connection error to the database.  The error message below has additional information, but you might need to ask the database administrator to review the database logs.
     
[Hortonworks][Support] (50363) Failed to get username: Routine Error: 
Unspecified GSS failure.  Minor code may provide more information.

Environment

  • Tableau Server 
  • Hortonworks Hadoop Hive
  • MIT Kerberos

Resolution

Verify the user which is configured as the Run As service account has execute permissions.  The user should be a Domain account .
 

Cause

The user which is configured as the Run As service account doesn't have the permission to obtain the Kerberos token.

Additional Information

Run the Tableau Desktop application on same machine with the Run As service account.  If the application is not able to start, grant the permission to that Run As service account user to execute the application. 

Run As Service Account

 
Did this article resolve the issue?