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Editing Connection in Tableau Server Results in Error: "Could not connect to server"


Published: 20 Feb 2019
Last Modified Date: 22 Feb 2019

Issue

When attempting to edit the connection of a published data source, an error occurs.  

When testing the connection, the error is:

"Could not connect to server"

When attempting to use the edited data source in a workbook, the error is:

"Unable to connect to the data source.
Try connecting again. If the problem persists, disconnect from the data source and contact the data source owner.
[Amazon][Amazon Redshift] (10) Error occurred while trying to connect [SQLState 3D000] FATAL: database "<database name>" does not exist.
Unable to connect to the Amazon Redshift server "<new server address>". Check that the server is running and that you have access privileges to the requested database.
DataServiceFailure
Unable to connect to the server "<old server address>". Check that the server is running and that you have access privileges to the requested database."

Environment

  • Tableau Server 2018.2.5
  • Amazon Redshift

Resolution

Change the database name in Tableau Desktop to one that does exist and can be used. Then republish the data source.

Cause

Tableau Desktop connects through an Security Device Manager (SDM) proxy, but Tableau Server does not, requiring that the data sources be edited after publishing.
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