KNOWLEDGE BASE

Disk Usage and Backup Size Increasing as Extracts Folder Growing in Tableau Server 2023.1.2, 2022.3.6, 2022.1.14


Published: 27 Jul 2023
Last Modified Date: 18 Sep 2023

Issue

Tableau Server C:\ProgramData\Tableau\Tableau Server\data\tabsvc\dataengine\extract folder grows daily causing disk usage and backup size to increase

Environment

  • Tableau Server versions:
    • 2021.2.24 (or below)
    • 2021.3.23 (or below)
    • 2021.4.18 (or below)
    • 2022.1.14 (or below)
    • 2022.3.6 (or below)
    • 2023.1.2 (or below)

Resolution

Option 1

Upgrade Tableau Server to one of the following versions and review the Salesforce Known Issue W-13476908:

  • 2021.3.25+
  • 2021.4.20+
  • 2022.1.16+
  • 2022.3.8+
  • 2023.1.4+

Option 2

Utilize resolution option 2 (Configure the Filestore connection timeout value) from the following Knowledge Base article:

Tableau Server Backups Are Failing At Verifying Disk Space in 2022.3.6 and 2023.1+

Details:

Within an administrative Command Prompt on the Controller node, apply the following configuration change:
 
tsm configuration set -k filestore.client.sockettimeoutms -v 0
tsm pending-changes apply (requires a restart)
 

Option 3

Where feasible and as a temporary measure until either of the above options can be implemented, utilize resolution option 1 from the following Knowledge Base article: 

Details:

  • Manually delete dataengine\extract\##\{FOLDERID}_TDFSTRNSFR\*.hyper files that are more than 24 hours old since last update date.
  • NOTE: Tableau Server can be running while deleting these files.
  • Even if there are no .hyper files in paths of this form, the Tableau Server may still be impacted by this issue. Do not delete *.hyper files in other subdirectories of the extract folder; this will create orphaned records within the Tableau Server Repository.

Cause

Backgrounder processes sometimes time out when attempting to retrieve lists of folderIDs that are no longer needed and can be deleted from the File Store processes.

More information can be found on the Salesforce Known Issue website with ID W-13476908 where the solution has been deployed.

Additional Information

Identifying a Match for this Issue


1. Confirm Tableau Server version matches list of impacted versions in Environment section above

2. Review C:\ProgramData\Tableau\Tableau Server\data\tabsvc\dataengine\extract (default installation path), and verify that folder size exceeds expectation, and that older files are not being reaped.

3. Inspect the Backgrounder logs whose file names begin with the word "backgrounder" (such as backgrounder_node1-0.log) and search for "Method:getFolderIds to File Store on host".  If found, the lines will resemble  "ERROR com.tableausoftware.tdfs.client.FileStoreService - Method:getFolderIds to File Store on host:<hostname>:<port> failed" where <host> is the hostname containing a File Store process, and <port> is the worker<node>.filestore.port assigned to the File Store.  The presence of such lines is a strong indicator that the Tableau Server is impacted by the issue described above.
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