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"Database error 0xC1000000: Unable to connect to the server" When Connecting to Microsoft Analysis Services from Tableau Server


Published: 01 Nov 2022
Last Modified Date: 01 Nov 2022

Issue

When connecting to Microsoft Analysis Services from Tableau Server 2022.1 and later, the following error may occur:

 Database error 0xC1000000:
Unable to connect to the server. Check that the server is running and that you have access privileges to the requested database.

 

Environment

  • Tableau Server 2022.1 and later
  • Windows
  • Microsoft Analysis Services

Resolution

1. Uninstall the incompatible MSOLAP (SQL_AS_OLEDB) driver or SQL Server Management Studio (SSMS) that includes the driver.

Note: Make sure that the below folder has been deleted after removing the MSOLAP driver. If the folder is still present, stop the Tableau Server by using the "tsm stop" command or from the TSM Web UI, then manually remove the folder:
C:\Program Files\Microsoft Analysis Services

2. Install the compatible MSOLAP (SQL_AS_OLEDB) driver version from the Tableau Driver Download page, such as 2014 SP1 (version 12.0.2000.8).
 

Cause

The MSOLAP driver version is incompatible with Tableau Server.
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