KNOWLEDGE BASE

Data Out-of-Date in Tableau Cloud Views


Published: 07 Mar 2014
Last Modified Date: 24 Aug 2022

Issue

After an extract is refreshed on Tableau Cloud, workbook views might not show the most up-to-date data. Selecting the "refresh" button on the view also does not display current data. 

Environment

  • Tableau Cloud
  • Tableau Desktop

Resolution

  1. Download the workbook from Tableau Cloud and open it in Tableau Desktop. For more information, see Download Workbooks.
  2. Open the workbook in Tableau Desktop.
  3. Select Data > New Data Source.
  4. Select Tableau Server.
  5. Log into Tableau Cloud.
  6. Select the published extract.
  7. Replace the original data source with the new data source. For more information, see Replacing Data Sources.
  8. Delete the original data source from the workbook.
  9. Republish the workbook to Tableau Cloud. For more information, see Publish Workbooks and Data Sources.

Cause

The workbook is connected to a local extract rather than the published data source.
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