KNOWLEDGE BASE

Cloudera Hadoop "Invalid OperationHandle" Error When Creating or Refreshing Extract


Published: 14 Feb 2020
Last Modified Date: 10 Feb 2021

Issue

The following error occurs intermittently when creating or refreshing extracts from a Hive data source:

"[Cloudera][Hardy] (35) Error from server: error code: '0' error message: 'Invalid OperationHandle: OperationHandle [opType=EXECUTE_STATEMENT, getHandleIdentifier()=]"

 

Environment

  • Tableau Server
  • Tableau Desktop
  • Cloudera Hadoop Hive

Resolution

Work with your database and network administrators to ensure that the network and database settings are configured properly. 

Cause

The error "Invalid Operation Handle" is generally caused by a misconfiguration which interferes with the communication between Tableau and the database. 
For example:
  • Load balancer configuration (Test this by connecting directly to the Cloudera node, bypassing the load balancer)
  • Kerberos authentication issues
  • Network Issues
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