KNOWLEDGE BASE

Cannot connect to Tableau Server when FQDN is used in URL


Published: 01 May 2022
Last Modified Date: 10 May 2022

Issue

Cannot connect to Tableau Server when FQDN is used in URL with the error below:

Network Error (tcp_error)
A communication error occurred "Connection refused"
The Web Server may be down, too busy, or experiencing other problems preventing it from responding to requests. You may with to try again at a later time.


Tableau Server can be connected via IP address.
 

Environment

  • Tableau Server

Resolution

Check with Server administrator to make sure the FQDN of Tableau Server is resolved to the correct IP address.

Below is a sample output of nslookup command on Windows client. Verify <Resolved IP address of your Tableau Server> is reachable from the client:

>nslookup <FQDN of your Tableau Server>
Server:  ***********************
Address:  <DNS IP address>

Non-authoritative answer:
Name:   <FQDN of your Tableau Server>
Address:  <Resolved IP address of your Tableau Server>


Please confirm the correct (reachable) IP address of Tableau Server is defined in DNS Server configuration. You might need to work with your network team to understand why DNS server returns 503 HTTP status code and to modify the name resolution on DNS.

Cause

Name resolution of Tableau Server host is incorrect. 

Additional Information

You will be able to confirm the following response details in the network trace collected by har file.

  • Request URL: http://<Tableau Server FQDN>/
  • Request Method: GET
  • Status Code: 503 Service Unavailable
  • Remote Address: <IP address of DNS Server>
Create and view HAR files 
Did this article resolve the issue?