KNOWLEDGE BASE

Ask Data in an Error State


Published: 07 Sep 2022
Last Modified Date: 16 Feb 2023

Issue

Ask Data is in an error state.

Environment

  • Tableau Server 2022.1 and newer

Resolution

Option 1

To resolve the issue due to Server secrets being corrupt from a previous attempt to regenerate internal tokens, run the following command again:
tsm security regenerate-internal-tokens
 

Option 2

As discussed in the Tableau Online Help, it is recommended to have an odd number of Elastic Server processes or Index and Search Server processes running in total.

On the cluster perform the following:

  1. Stop Tableau Server then perform steps 2-4 on each node.
  2. On each node navigate to C:\ProgramData\Tableau\Tableau Server\data\tabsvc\indexandsearchserver\0\nodes\0\
  3. Zip the contents of this folder (select and then zip the two folders, "_state" and "indices", contained within) as "_state<node number here>".zip
  4. Leave the zip in the nodes\0\ folder and then delete the "_state" and "indices" folders.
  5. In the TSM UI, remove indexandsearchserver from the other nodes, leaving the process only on the master node.
  6. Apply-pending changes
  7. Start Tableau Server
If the ask data comes back up on the primary node, then you can apply new indexandserchserver processes to the other nodes in the cluster but remember it is recommended to have an odd number of Elastic Server or Index and Search Server processing running in total.



 

Cause

  • Environmental or incorrect number of processes.
  • Server secrets may be corrupt which can occur when regenerating the internal tokens did not complete successfully.

Additional Information

To determine if Option 1 is needed, the following information will be seen occurring in a loop in the Elasticsearch and Ask Data log set:

2020-07-13 17:00:48.630 +0800 96666 main : INFO com.tableausoftware.nlp.NLPApp - Executing command with args [[getSecret]]
2020-07-13 17:00:49.429 +0800 96666 main : INFO com.tableausoftware.nlp.NLPApp - OK
2020-07-13 17:00:50.717 +0800 96692 main : INFO com.tableausoftware.nlp.NLPApp - Executing command with args [[getResponseSecret]]
2020-07-13 17:00:51.576 +0800 96692 main : INFO com.tableausoftware.nlp.NLPApp - OK
2020-07-13 17:00:52.681 +0800 96832 main : INFO com.tableausoftware.nlp.NLPApp - Executing command with args [[getElasticPassword]]
2020-07-13 17:00:53.310 +0800 96832 main : INFO com.tableausoftware.nlp.NLPApp - OK

[2020-07-13T17:00:53,500][WARN ][c.f.s.a.BackendRegistry ] Authentication finally failed for admin
 
Did this article resolve the issue?