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An error occurred while communicating with Tableau Data Engine. Bad Connection: Tableau could not connect to the data source. There was problem and the data engine could not start properly


Published: 26 Apr 2019
Last Modified Date: 16 Jun 2020

Issue

When attempting to connect to a data source, the connection will fail if the My Tableau Repository location does not allow Tableau to update the files.

This issue most often occurs when attempting to open an Excel document in Tableau Desktop. The connection works, but the data does not appear. An error occurs displaying:
 
An error occurred while communicating with Tableau Data Engine. Bad Connection: Tableau could not connect to the data source. There was problem and the data engine could not start properly.

Similar issues may occur after upgrading Tableau Desktop, when a user attempts to open a pre-existing workbook. The workbook views open, but the data source is unable to connect. The data source is accessible from outside of Tableau Desktop. In addition to the above error message, the below may appear:
 
There was a problem connecting to the data source "XXXXX"
Would you like to edit the connection information.

Environment

  • Tableau Desktop
  • Windows OS
  • Various data sources

Resolution

Follow these steps to resolve the issue:
  1. Check the My Tableau Repository location and make sure there are no restrictions to reading and writing files from the local computer or user account to the My Tableau Repository folder.
  2. If needed, move the My Tableau Repository location to a folder path that has no restrictions to reading and writing files. For more information, see Changing the My Tableau Repository Location.
  3. Rename the logs folder to "logs_backup".  
  4. Restart Tableau Desktop

Cause

Restrictions on accessing the My Tableau Repository folder will cause Tableau Desktop to show these errors. In addition to the errors, the My Tableau Repository location is not writing new files.
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