KNOWLEDGE BASE

After Reboot Workers Nodes Are Not Coming Up and No Registration File Found


Published: 15 Oct 2018
Last Modified Date: 15 Mar 2022

Issue

Customer rebooted Windows Server and the Tableau Server processes show failed. When looking at the status pane, all the licenses services on the nodes show failing.

Environment

  • Tableau Server 2018.2.2
  • Windows Server
  • Linux

Resolution

  1. The resolution is to ensure that the Firewall does not block the traffic to Tableau Server.
  2. Add a Firewall rule to allow traffic between Tableau Servers, so that the licensing services does not fail to register. 

Run tsm topology list-ports from a command line.
Note ports specifically "licenseservice:vendor_daemon". In the firewall create a rule to allow the following tcp connection (on each node): 27000.

Hard code the Licensing Server port using TSM topology set-ports for the node where the "License Service" is installed.

tsm stop
tsm topology set-ports --node-name node1 --port-name licenseservice:vendor_daemon --port-value 27000
Restart licensing services
tsm restart

Cause

This error is generic and could be related to different root cause.
The licensed services failed to load and it was due to the nodes not registering properly. (INFO- com.tableausoftware.config.ServiceRegistrationInfoFile shows no registration file found.)
The issue occurs when firewall block Licensing server traffic between windows servers. 

Additional Information

To test the issue

Windows
  1. Run tsm topology list-ports.
  2. look for licenseservice:vendor_daemon (License service vendor daemon port).
  3. Ensure that the Windows Firewall is not blocking traffic to the ports for the Licensing server. 
You can also try to disable the Windows Firewall and see if restarting the server using TSM Start helps to resolve the issue. 

To check if the port have been set properly

Linux

cat /var/opt/tableau/tableau_server/data/tabsvc/config/licenseservice_0.<version>/tableau.lic
sudo netstat -ltnp | grep -w ":27000"

For more information, see Tableau Services Manager Ports.
Did this article resolve the issue?