KNOWLEDGE BASE

After Changing User Active Directory Password the Account is Locked Out Due to RMT


Published: 20 Apr 2023
Last Modified Date: 21 Apr 2023

Issue

After changing an AD password, the AD account is locked out.  All the lock-out messages indicate the logon request is coming from Tableau Server.

The Event Viewer on Tableau Server in the Security events shows Event XXXX indicating that process run-vizportal.exe processed a logon request for the AD account and it failed. Within a minute the AD account locks due to the domain lockout policy. Following are the details from an example Event XXXX:

An account failed to log on.

Subject:
Security ID: XXXX\XXXX
Account Name: tableauuser
Account Domain: tableau.com
Logon ID: 0x16950E

Failure Information:
Failure Reason: Account locked out.
Status: 0xC0000234
Sub Status: 0x0

Process Information:
Caller Process ID: 0x16e8
Caller Process Name: E:\Tableau Server\packages\bin.20204.22.0111.1927\run-vizportal.exe

This event extract is generated when a logon request fails. It is generated on the computer where access was attempted.

Environment

  • Tableau Server
  • Tableau Advanced Management - RMT
  • Active Directory

Resolution

The Tableau Resource Monitoring Tool was generating the login requests to Tableau Server using an old password.  The resolution is to update the password in the Tableau Resource Monitoring Tool or uninstall the RMT tool if not used.
 

Cause

Tableau Resource Monitoring (RMT) was using the old credentials.
Did this article resolve the issue?