KNOWLEDGE BASE

Activation Service Logs Are Too Large


Published: 19 Nov 2021
Last Modified Date: 19 Nov 2021

Issue

Tableau Server activationservice_nativeapi logs increase at an unexpected rate and consume excessive disk space.

Environment

  • Tableau Server v2021.1, v2021.2, and v2021.3 - v2021.3.1
  • Authorization-To-Run (ATR)

Resolution

This behavior is related to a known issue, ID 1321039, which is currently under investigation.
As a workaround for this issue, follow these steps:
 
1. Open an Administrator command prompt
2. Run the following two commands:
 
tsm configuration set -k activationservice.native_api.log.level -v warn
tsm pending-changes apply

3. Once Tableau Server has restarted, go to the Windows menu and open Services.msc. Locate the Tableau Activation Service and restart it from this UI.

Cause

This behavior is related to a known issue ID 1321039 which will be resolved in a future release of the product.

Additional Information

Note: The current mitigation for this issue will reduce the verbosity of logging for the Activation Service, and may interfere with troubleshooting for licensing issues. For this reason, please watch our known issues page (ctl + f for 1321039) to be able to upgrade to a version with a more permanent resolution to this issue.

Once you have upgraded Tableau Server, please revert this change by following the above steps and changing -v warn to -d.

For more information, see Activate Tableau Server Using the Authorization-To-Run (ATR) Service
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