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Action Filter Resets Quick Filter


Published: 01 May 2014
Last Modified Date: 20 Jul 2018

Issue

When you make selections in a Quick filter and then click an Action filter, the Quick filter selections might be cleared.

Environment

Tableau Desktop

Resolution

Option 1: Make A Copy of a Dimension and Use that as a Replacement for the Original

  1. Right-click the quick filtered field and select  'Duplicate'.
  2. Use the duplicate in place of the original on the filters shelf.
Note: With the above option, it's possible to get conflicting filters between the action and quick filter.


Option 2: Modify the Filter Action

  1. Open the workbook in Tableau Desktop.
  2. Navigate to the dashboard, and select Dashboard > Actions.
  3. Select the Filter Action, and then click Edit.
  4. Under Target Filters, select Selected Fields.
  5. Click Add Filter.
  6. In the Source and Target drop-down menus, choose the desired field to filter, and then click OK three times.

Cause

This is by design to avoid mutually exclusive filters.
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