KNOWLEDGE BASE

Error "The sign-in was unsuccessful. Try again." Occurs When Attempting To Sign In To The SAML-Enabled Tableau Online Site


Published: 17 Oct 2017
Last Modified Date: 20 Aug 2020

Issue

When attempting to sign in to Tableau Online, the following error occurs:
The sign-in was unsuccessful. Try again.
If you continue to get this message, capture the status information below, and send it to Customer Support.

 
User-added image

Environment

  • Tableau Online
  • SAML

Resolution

Solution:
Make sure the assertions sent by IdP match the assertions Tableau Online expects.

Example (Azure AD): If you’ve configured Microsoft Azure Active Directory (Azure AD) as your SAML identity provider (IdP), the assertion will be the following
http://schemas.xmlsoap.org/ws/2005/05/identity/claims/emailaddress or http://schemas.xmlsoap.org/ws/2005/05/identity/claims/name 
For more information see Match assertions (Azure AD).
User-added image


Workaround:
Revert the user account to TableauID instead of SAML Authentication. See Set the User Authentication Type.

Cause

Login failed because the mapping of assertions is incorrect. The site admin needs to either choose the correct attribute or set the User Authentication Type to TableauID.

Additional Information

Since the username in Tableau Online is an email address. At a minimum, Tableau Online needs an email address for matching expected assertions.
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