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Error "The Connection to the data source might have been lost" When Attempting to Refresh an Extract Using an Amazon Redshift data source


Published: 07 Mar 2018
Last Modified Date: 17 Jul 2020

Issue

While using Amazon Redshift data source, when the data refresh action is started in Tableau Server, then the following error occurs. 
The Connection to the data source might have been lost. ExternalProtocol::PipeMessageSource::ReadBytes:Communication with the Tableau Protocol Server process was lost.

While using Amazon Redshift data source, when an extract from the data source in Tableau Server is requested, then the following Tableau Desktop error occurs.
The Connection to the data source might have been lost. ExternalProtocol::PipeMessageSource::ReadBytes:Communication with the Tableau Protocol Server process was lost. Unable to create extract.
Unhandled exception: 0xc0000005

 

Environment

  • Tableau Server v.10.5.0
  • Tableau Desktop v.10.5.1
  • OS = Windows Server 2012
  • Datasource = Amazon Redshift
  • Amazon Redshift Driver version in use at the time the issue happened: v.1.2.1.1001
  • Amazon Redshift Driver version in use at the time the issue was resolved: v.1.3.7.1000

Resolution

Create a file with .TDC extension with the following content. Use this file for both Tableau Server and Tableau Desktop.
NOTE: the .TDC content below is only for Amazon Redshift data source.

<?xml version='1.0' encoding='utf-8' ?>
<connection-customization class='redshift' enabled='true' version='8.10'>
<vendor name='redshift'/>
<driver name='redshift'/>
<customizations>
<customization name='CAP_ODBC_EXPORT_BIND_FORCE_TARGET_METADATA' value='yes' />
<customization name='CAP_ODBC_EXPORT_FORCE_SINGLE_ROW_BINDING' value='yes' />
<customization name='CAP_ODBC_REBIND_SKIP_UNBIND' value='yes' />
<customization name='CAP_ODBC_UNBIND_EACH' value='no' />
<customization name="CAP_ODBC_CONNECTION_STATE_VERIFY_PROBE_PREPARED_QUERY" value="no" />
</customizations>
</connection-customization>

Copy/Save the .TDC file in the relevant folder for Tableau Server and Tableau Desktop; see the links in the Related Links field below for the path where to save the .TDC file.

Cause

This issue may be related to the Amazon Redshift driver.
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