KNOWLEDGE BASE

Tableau Server Resource Monitoring Tool Not Showing CPU/Processor Data


Published: 14 Oct 2020
Last Modified Date: 15 Oct 2020

Issue

The Tableau Resource Monitoring Tool is not displaying Processor information in the Performance tab for connected Agent machines.
The Agent Resource Monitoring Tool background log will show something like the following:

"Error running WMI query \"SELECT Name, PercentProcessorTime, Timestamp_Sys100NS FROM Win32_PerfRawData_PerfOS_Processor\""

Environment

  • Tableau Resource Monitoring Tool
  • Windows Server

Resolution

To resolve this issue, run through the following steps.

Step 1: Rebuild the performance counters

Follow the guide presented in the article linked below

Troubleshoot WMI Query Issues

Step 2: Check and adjust the registry if performance counters are disabled
  1.  Within the Registry Editor, navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\PerfOS\Performance
  2.  If the Name column contains 'Disable Performance Counters' and the value is set to 1, change this value to 0.
  3.  Save the change and reboot the server for this change to take effect.
If the steps above do not resolve this issue, please gather the Tableau Resource Monitoring Tool logs from the Master and Agent servers and contact Tableau Support.

Sending RMT Log files to Tableau Support

Cause

If the WMI class is missing or if the performance counters for this WMI class is disabled, the Agent will not be able to query and report CPU information to the Master server.
Did this article resolve the issue?