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Tableau Bridge Worker Service Doesn't Startup Automatically After Rebooting, Events 7000 And 7009 Are Logged In The Windows Event Viewer


Published: 22 May 2020
Last Modified Date: 15 Jul 2020

Issue

When running Tableau Bridge in Service mode with a local administrator account on the computer, Tableau Bridge doesn't automatically start up after rebooting the computer. 
The following errors are logged in the Windows Event Viewer.

Log Name: System
Source: Service Control Manager
Event ID: 7000
Level: Error
Detail:
A timeout was reached (30000 milliseconds) while waiting for the Tableau Bridge worker(<username>@<domainname>) service to connect.


Log Name: System
Source: Service Control Manager
Event ID: 7009
Level: Error
Detail:
The Tableau Bridge worker(<username>@<domainname>) service failed to start due to the following error: The service did not respond to the start or control request in a timely fashion.

Environment

  • Tableau Bridge

Resolution

Follow the following solution to increase the timeout for the Windows Service Control Manager(WSCM). After restarting the computer, WSCM can allow more time for service to start. The default value is 30000 milliseconds (30 seconds).
Microsoft Docs: Event ID 7009 — Basic Service Operations

Cause

Tableau Bridge worker service is timed out starting automatically after rebooting the computer.
This issue may related to the low specification of the computer running Tableau Bridge.

Additional Information

Registry changes might cause some expected problems on your computer. For added protection, back up the registry before you modify it. For more information about how to back up and restore the registry, review the following article in Microsoft Knowledge Base.
How to back up and restore the registry in Windows
 
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