KNOWLEDGE BASE

Flow Job Pending with "cannot run because your site has reached its concurrency limit for extract refreshes"


Published: 07 Dec 2020
Last Modified Date: 09 Dec 2020

Issue

Unable to run a published flow in Tableau Online when you set the schedule for running flow.
The flow job is pending with the following message:

"This job has been queued for XX minutes and cannot run because your site has reached its concurrency limit for extract refreshes"

User-added image

Environment

  • Tableau Online 2020.4

Resolution

Option 1

Run/schedule the flows one by one if you have 1 Resource Block.
 

Option 2

Purchase Data Management Add-On and/or Resource Block if you haven't done so.
 
The same message occurs even if there are no resource blocks at all.
"This job has been queued for XX minutes and cannot run because your site has reached its concurrency limit for extract refreshes"
 You need to purchase the Resource Blocks (Data Management Add-on) for setting schedule for flow.
 

Cause

One Resource Block is added when you purchase Data Management Add-On license. 
This error occurs when you try to schedule more flows than the number of Resource Blocks you have. You can schedule 1 flow for 1 Resource Block.
Or, you tried to schedule a published flow without purchasing Data Management Add-on license (therefore no Resource Block is available).

 

Additional Information

It is possible to publish a flow and manually run it on Tableau Online but Data Management Add-On is required to schedule flows on Tableau Online.
Did this article resolve the issue?