KNOWLEDGE BASE

Extract refresh failed with error "Could not connect to the Hyper server"


Published: 06 Aug 2020
Last Modified Date: 11 Aug 2020

Issue

Extract refresh failed with the following error:

2020-07-15T18:11:45.819: 17048-9a4 EXTRACT-TASK
    message : Error rolling back extract task: Hyper API: Could not connect to the Hyper server.
        The Hyper server closed the connection unexpectedly.
        The server process may have been shut down or terminated before or while processing the request.

The following output/error is confirmed in hyper log:

{"ts":"2020-07-15T18:11:21.803","pid":11304,"tid":"2df0","sev":"info","req":"-","sess":"-","k":"srm-internal","v":{"msg":"Resource Manager: CPU reclamation was unsuccessful. Process has to be terminated."}}

Environment

  • Tableau Server

Resolution

Add more CPU cores.

Cause

Insufficient CPU resource to complete the extract refresh job can cause this error.
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