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Error "unable To Connect To The Postgresql Server <Instance>.<Pod>.rds.amazonaws.com" When Connecting To Or Refreshing A Published Postgres Extract


Published: 20 Jul 2020
Last Modified Date: 21 Jul 2020

Issue

When attempting to refresh a published Postgres extract hosted on Amazon AWS RDS, the following error is returned:

Connectionless Failure (status code = 10000, One or more connections in this data source need attention: <instance>.<pod>.rds.amazonaws.com: timeout expired
Unable to connect to the PostgreSQL server "<instance>.<pod>.rds.amazonaws.com". Check that the server is running and that you have access privileges to the requested database.)

Environment

  • Tableau Online
  • Amazon AWS RDS
  • PostgreSQL

Resolution

Ensure the Tableau Online IPs for the customer's pod have been whitelisted in AWS per our documentation, configured so that the Type is set to PostgreSQL. This should automatically set the port to 5432.

e.g.:
User-added image

Tableau Online: Keep Data Fresh

Cause

Postgres instances hosted on AWS RDS must use the PostgreSQL connection type with port 5432, instead of HTTP/HTTPS with ports 80/443.
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