KNOWLEDGE BASE

Error: "an Error Occurred On The Server Collecting Log Archives" Occurs At "100% - Writing Ziplogs Archive To Disk" When Creating Tableau Server Logs


Published: 10 Dec 2019
Last Modified Date: 02 Jul 2020

Issue

When running tsm maintenance ziplogs or creating logs using the TSM web UI, the error occurs:

100% - Writing ziplogs archive to disk
An error occurred on the server collecting log archives.
This job failed due to an error.

The generated log archive is present in <install path>\data\tabsvc\files\log-archives, but part of the access log missing.

Environment

  • Tableau Server

Resolution

As potential workarounds: 

Option 1:

Run the ziplogs command with Tableau Server stopped.
 

Option 2:

Review the contents of the ziplogs for the "errors.txt" file in the tabadminagent folder. Example of the file path:
<path\to\extracted\logs>\ziplogs\node1\tabadminagent_0.20193.19.0913.22258502758426887061009\logs\errors.txt

The contents of errors.txt will look similar to the following example (file location and name are in bold):
 
C:\ProgramData\Tableau\Tableau Server\data\tabsvc\logs\httpd\access.2019_11_20_00_00_00.log: java.io.IOException: The process cannot access the file because another process has locked a portion of the file
 
Manually copy any files listed with this message to another location and provide them to Tableau Technical Support with the ziplogs archive.

Option 3:

Upgrade Tableau Server to 2019.3.7, 2019.4.6, 2020.1.3 or later.

 

Cause

This is a known issue that was addressed in Tableau Server with the versions below:
Tableau Server 2020.1.3 or later
Tableau Server 2019.4.6 or later
Tableau Server 2019.3.7 or later
 
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