BASE DE CONOCIMIENTO

Solución del error "Worker Initialization Failed"


Publicado: 17 Apr 2015
Fecha de la última modificación: 12 May 2020

Problema

Al instalar, actualizar o iniciar Tableau Server, podría producirse el siguiente error en la utilidad de configuración de Tableau Server:
 
Worker initialization failed. (Error de inicialización del nodo trabajador)
See the tabadmin.log for details. (Consulte el archivo tabadmin.log para obtener más detalles.)
 
Nota: el error "Error de inicialización del nodo trabajador" también puede producirse en una única instalación en el equipo de Tableau Server porque el "nodo trabajador" que ha fallado podría ser el nodo principal (por ejemplo, el nodo trabajador 0).

Entorno

Tableau Server

Solución

Primero, compruebe los permisos:

  • Asegúrese de que el usuario que está instalando Tableau Server y la cuenta Ejecutar como usuario tengan los permisos necesarios para efectuar la instalación en el directorio de instalación. Para obtener más información, consulte Configuración de la cuenta Ejecutar como usuario necesaria.
  • Asegúrese de que los archivos y las carpetas de Tableau no tienen el atributo "Solo lectura" seleccionado. Para obtener más información, consulte Permisos de archivos y carpetas en Microsoft TechNet.
  • Asegúrese de que la cuenta "LocalService" cuenta con los permisos adecuados para la raíz de la unidad donde está instalado Tableau Server.
Nota: Es especialmente importante comprobar la cuenta Local Service si ha actualizado una versión anterior de Tableau Server a la versión 9.3 o posterior.El servicio de licencia de Tableau comenzó a funcionar con la cuenta Local Service en Tableau 9.3.

Restablecimiento del servicio de coordinación (Zookeeper)


Si Zookeeper no se inicia correctamente, aparecerá un error en los registros similar al que se muestra a continuación:
user=__request=__ Sending 'ruok' to localhost:12000...user=__request=__ Error getting ZooKeeper state: Errno::ECONNREFUSED:Connection refused - Connection refused
En este caso, puede que ejecutar el comando "tabadmin cleanup --reset -coordination" solucione el problema. Para obtener más información, consulte Comandos de tabadmin: cleanup,
Nota: Archive sus registros antes de ejecutar el comando de arriba. Dicho comando eliminará todos los archivos de registro. Para obtener más información, consulte Trabajar con archivos de registro.

Asegúrese de que los puertos necesarios están abiertos

Asegúrese de que los puertos que necesita Tableau Server están abiertos.

Búsqueda de puertos disponibles

Durante la instalación y el inicio, Tableau Server buscará puertos disponibles para sus procesos.

Ejemplo:

Comprobación de un intervalo de 1 puerto para pgsql.port, default 8060.
Comprobación de un intervalo de 1 puerto para worker0.vizqlserver.port, default 9100.
Iniciar: se ha terminado de configurar los puertos después de crear la configuración inicial
Si un puerto predeterminado no estuviera disponible para enlazar, dicha información se separará del registro.

Abrir puertos durante la instalación

Durante la instalación, Tableau Server abre puertos en Windows Firewall en el ámbito de SUBRED. Por ello, recomendamos que todos los equipos en un clúster de Tableau Server tengan la misma subred IP.

  • Según las reglas de firewall predeterminadas, los equipos no podrán conectarse si lo hacen desde fuera de la subred IP. Si tiene equipos en el clúster con diferentes subredes IP, deberá establecer las reglas de firewall de forma manual.
  • Tableau Server no intentará abrir puertos en ningún otro firewall, solo en Windows Firewall.

Usar telnet para comprobar puertos

Telnet Client es un programa de Microsoft que se puede instalar en la mayoría de los entornos de Windows Server. Para obtener más información, consulte Instalar Telnet Client en Microsoft Technet. Aquí se muestran los puertos específicos que Tableau Server utiliza de forma predeterminada: Puertos de Tableau Server.

 comprobar que el nodo principal de Tableau Server se puede comunicar con un nodo trabajador para completar la instalación de un trabajador mediante el puerto 3730, deberá someter a la instancia principal a la siguiente prueba:

Si el nodo trabajador se ha agregado utilizando la dirección IP : telnet <workerIP> 3730
Si el nodo trabajador se ha agregado utilizando el nombre de máquina: telnet <worker-machine-name> 3730

Para garantizar que el nodo trabajador puede alcanzar el proceso administrativo de Tableau de la instancia principal:

Del nodo trabajador: telnet <primary-machine-name> 8755

Para comprobar si un nodo trabajador se puede comunicar consigo mismo en un puerto, deberá utilizar el localhost o el 127.0.0.1 de la máquina del nodo trabajador:

Del nodo trabajador: telnet localhost <port>

Si la prueba de telnet da un buen resultado, verá una pantalla en blanco.
Si la prueba de telnet da un mal resultado, verá un error como el siguiente:
Conectando con localhost... no se ha podido abrir la conexión para el host en el puerto <number>: 
Error en la conexión
.
El error que se muestra arriba indica que la comunicación está bloqueada o que no hay ningún proceso ejecutándose en el puerto seleccionado.
Asegúrese de que no hay configurado ningún proxy, firewall o antivirus para que Tableau Server pueda comunicarse con los puertos necesarios.Para obtener más información, consulte Configurar proxies para Tableau Server y Mejorar el rendimiento utilizando extensiones de antivirus.

Causa

Por norma general, este error suele ocurrir porque Ejecutar como usuario o la cuenta Local Service no tiene permisos suficientes, Zookeeper no se ha iniciado correctamente o los puertos necesarios para comunicarse con Tableau Server están bloqueados.
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