Error "Unable to connect to data source with the supplied credentials" Connecting to or Refreshing Google Drive or OAuth Data Source
Published: 12 Dec 2019 Last Modified Date: 17 Mar 2021
Issue
Published Google Drive or OAuth Data Sources and workbooks fail to connect or refresh with the following error:
Unable to connect to data source with the supplied credentials
Environment
Tableau Online
Tableau Server
Google Drive
OAuth Data Sources
Resolution
Delete and Re-Add Saved Credentials for all Affected Connections
While you’re signed in to Tableau Server or Tableau Online, display your Account Settings page.
Under Saved Credentials for Data Sources, select Delete for the username next to the affected data source.
Select Add and re-enter the data source account credentials.
Note: If you have published connections that do not use saved credentials, see Edit Connections on Tableau Online for steps to update them.
Cause
Access tokens may expire at times depending on a variety of reasons from the data provider. If authentication is failing to the data source, then generating new access tokens can resolve many of these connectivity issues.
Thank you for providing your feedback on the effectiveness of the article.