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Error 'The provided grant or refresh token is invalid.' When Refreshing OAuth Based Data Source in Tableau Online


Published: 28 Jan 2021
Last Modified Date: 01 Feb 2021

Issue

When refreshing OAuth based data sources in Tableau Online, the following error occurs:

Connectionless Failure (status code = 10000, Unable to connect to the data source with the supplied credentials, or no credentials provided.
Unable to authenticate using supplied user credentials.
{"InternalStatusCode":400,"message":"The provided grant or refresh token is invalid."}

Environment

  • Tableau Online
  • Oauth

Resolution

1. Navigate to the My Account Settings page for the owner of the data source (profile icon in the top right of the Tableau Online home page).
2. Select Delete for the data source type experiencing the issue., and confirm to delete the saved credentials.
3. Select Add for the same credentials, and re-enter the same credentials that were used before.
4. Ensure the credentials have been successfully re-added to your saved credentials, and try to run the refresh again.

Note: Removing and re-adding the credentials refreshes the OAuth token validity period, and allows the refresh to begin succeeding again for all the specific data sources failing. For adjusting the token validity period, please see the documentation from your data source provider, or reach out to the support team specific to your data source type.

Cause

OAuth tokens have set validity periods before they expire (default is typically 90 days). Removing and re-adding the credentials in the saved credentials section refreshes the OAuth token validity period, and allows the refreshes to begin succeeding again. For adjusting the token validity period, please see the documentation from your data source provider, or reach out to the support team specific to your data source type.
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