KNOWLEDGE BASE

Early End-of-Maintenance for Tableau Products


Published: 26 Jul 2021
Last Modified Date: 11 Nov 2021

Issue

During a recent security review of our products, we identified that Tableau Server versions 2019.3.x - 2020.3.x embed a version of PostgreSQL Database (PGSQL 9.6) that will no longer be supported as of November 11, 2021. That means that any PostgreSQL security vulnerabilities discovered in that version after November 11, 2021 will no longer be fixed by the stewards of PostgreSQL. To address this issue, and meet our commitment to security for our customers, we are accelerating the End-of-Maintenance timeline for the five versions of the Tableau Desktop and Server product that include this embedded component. 

What is the impact?
The end-of-maintenance date for Tableau versions 2019.3.x, 2019.4.x, 2020.1.x, 2020.2.x, and 2020.3.x is now November 11, 2021. Customers running one of these versions can elect to continue using it and get support through the Tableau Technical Support process, however, after November 11, 2021, there will be no new security fixes, defect corrections, or monthly maintenance releases for these versions. This change also applies to companion client software for these versions, including Tableau Desktop, Tableau Prep, Resource Monitoring Tool, Content Migration Tool, and others. You should upgrade to version 2020.4 or newer as quickly as possible.

Environment

Tableau Server and Client Products such as Desktop, Prep Builder, Resource Monitoring Tool, Content Migration Tool
- 2019.3.x
- 2019.4.x
- 2020.1.x
- 2020.2.x
- 2020.3.x

Resolution

To stay on actively maintained software, take the following actions:

  1. Verify if you are running one of these versions by following the steps in the Finding Your Tableau Version and Build Number Knowledge Base article.
  2. If you are on version 2020.3.x or older, upgrade to 2020.4.x or newer as soon as possible. 
 

The additional resources below are available to assist in the upgrade process.

 

Special note for Server Management Add-on customers who deploy Tableau in AWS

As a customer who deploys Tableau Server in AWS with the Server Management Add-on and External Repository feature, note that, on January 18, 2022, Amazon will automatically upgrade Amazon RDS instances running PostgreSQL 9.6 to PostgreSQL 12. If you are running Tableau Server 2020.3 or older with the External Repository feature, this will render your Tableau Server unusable because PostgreSQL 12 is not a supported version prior to Tableau 2020.4. In addition, a Tableau Server backup will fail after an automatic upgrade to PostgreSQL 12.

 

To continue using an external repository configuration with Amazon RDS, you must upgrade to Tableau Server version 2020.4 or newer and upgrade Amazon RDS to PostgreSQL 12 before January 18, 2022. Any customer with Tableau Server version 2020.3 or older that is in the process of testing this configuration and planning to deploy in production should instead deploy Tableau 2020.4 or newer.

Did this article resolve the issue?