Cannot Sign In Tableau Cloud From Tableau Desktop When Using Client Certificate For SAML Identity Provider (Idp) Authentication
Published: 05 May 2020 Last Modified Date: 08 Jun 2022
Issue
Cannot sign in Tableau Cloud from Tableau Desktop when using client certificate for SAML identity provider (Idp) authentication. The issue doesn't occur when using a Web browser or connecting through a virtual private network (VPN).
Environment
Tableau Desktop
SAML
client certificate (require the client to authenticate with a certificate)
Tableau Cloud
Tableau Server
Resolution
Workaround 1 Disable SAML for Tableau Desktop in Tableau Server. 'tsm authentication saml configure --desktop-access disable'
Workaround 2 Use Tableau Prep to publish a data source, and use WebAuth for creating the workbook.
Cause
The version of Qt WebEngine that being used in Tableau Desktop does not support client certificates currently.
Additional Information
The following error message might be recorded in the Tableau Desktop log (log.txt): "...because it violates the following Content Security Policy directive..."
Thank you for providing your feedback on the effectiveness of the article.