KNOWLEDGE BASE

Error 0x80070666 Installing Tableau Desktop, Tableau Prep, Tableau Reader, or Tableau Server


Published: 19 Oct 2017
Last Modified Date: 20 Jan 2022

Issue

When trying to install Tableau Desktop, Tableau Prep or Tableau Reader, the following error occurs:
 
"Error 0x80070666"

Or
"Tableau Prep 2018.1.2 (18.12.18.0606.1647) Setup Failed
One or more issues caused the setup to fail. Please fix the issues and then retry setup. For more information, see the log file.
0x80070666 - Another version of the product is already installed..."

Environment

  • Tableau Desktop
  • Tableau Prep
  • Tableau Reader
  • Tableau Server
  • Windows
  • Visual C++ Redistributable 2017
  • Visual Studio 2017

Resolution

  1. Uninstall Visual C++ Redistributable 2017 
  2. Redo the Tableau installer steps applicable
  3. Reinstall Visual C++ Redistributable 2017
NOTE: If the above does not work, please verify in Control Panel > Programs & Features that Microsoft Visual C++ Redistributable 2017 has been uninstalled. Also verify at the C:/ drive at the directory for Tableau temp files. If Visual C++ 2018 still is at either location, uninstall Visual C++ again and reboot the computer. Then proceed to reinstall the Tableau packaged executable.

Once Tableau has successfully installed, reinstalling the Visual C++ Redistributable 2017 should be fine. Latest builds can be found here: https://visualstudio.microsoft.com/downloads/#microsoft-visual-c-redistributable-for-visual-studio-2017-rc

Cause

When Tableau is installed, part of the installation is VC_redist for 2015.
VC_redist for 2017 will not allow an earlier version of VC_redist to be installed, causing the installation of Tableau to fail.
Did this article resolve the issue?