KNOWLEDGE BASE

After upgrading Tableau Server from 2020.2.5 to 2020.3.4, some users fails to sign in with Site-specific SAML authentication and the request is redirected to /#/error page


Published: 20 Jan 2021
Last Modified Date: 17 Feb 2021

Issue

After upgrading Tableau Server from 2020.2.5 to 2020.3.4, some users fails to sign in with Site-specific SAML authentication and the request is redirected to /#/error page.
User-added image
 

Environment

  • Tableau Server 2020.3.3, 2020.3.4, 2020.3.5, 2020.4.0, 2020.4.1 upgraded from earlier versions of Tableau Server.
  • Site-specific SAML is enabled and users were configured to sign-in to Tableau Server 

Resolution

Workaround 1

  1. After enabling Server Default authentication for affected users by clicking "Users" > "More actions" (displayed as "...") in the affected user > "Authentication" > "Server Default" > "Update" in the top page of Tableau Server. 
  2. Re-enable Site-specific SAML authentication by clicking "Users" > "More actions" (displayed as "...") in the affected user > "Authentication" > "<The name of Site-specific SAML authentication>" > "Update" in the top page of Tableau Server.

Workaround 2

Delete the affected users by the following procedures:
  1. Select "Users" in the top page of Tableau Server
  2. Select the checkbox in the row of affected users
  3. Select "Actions" > "Remove".
Then register them again by the following procedures:
  1. Select "Users" > "Add users" > "New User" in the top page of Tableau Server.
  2. Check "Add users for <The name of Site-specific SAML authentication>".
  3. Fill out fields such as username, email address and so on.
  4. Select "Add User"

Cause

The issue is under investigation by development team as Issue ID: 1218852.
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