KNOWLEDGE BASE

Compatibility of Visual C++ Redistributable Packages with Tableau


Published: 24 Nov 2021
Last Modified Date: 25 Nov 2021

Question

Will the currently installed Visual C++ Redistributable packages in my environment work with Tableau Desktop?

Environment

  • Tableau Desktop
  • Windows

Answer

Tableau installers include the Visual C++ Redistributable packages that the application requires. Tableau applications have not been tested with other versions of Visual C++ Redistributable packages that are not included with the installers.

For example, the Visual C++ Redistributable packages that are included with the Tableau Desktop 2021.2.1 installer are vcredist2013_x64 (12.0.40649.5) and vcredist2019_x64 (14.27.29016.0). When running the Tableau Desktop .exe installer, the installation process will check that vcredist2013_x64 and vcredist2019_x64 are installed before running the Tableau Desktop .msi installer. If vcredist2013_x64 and vcredist2019_x64 are not installed, the installation process will install them, before running the Tableau Desktop .msi installer.

You can carry out the following steps to test whether the currently installed vcredist versions are compatible:
  1. Run the Tableau Desktop .exe installer in the user environment.
  2. Review the installation log to see whether the currently installed vcredist versions are detected by the installation process, and the bundled vcredist versions are installed.
  3. Verify that Tableau Desktop works as expected (e.g. launches successfully). 
Did this article resolve the issue?