ナレッジベース

Users From New Domain Unable to Log In and Do Not Appear in User List


発行: 08 Feb 2016
最終修正日: 03 Jan 2020

問題

After adding a user from a new domain, the user is only able to login using the fully qualified domain name (FQDN), but not NetBIOS name (“nickname”) of the domain. I.e. User is added from domain with FQDN “us.company.com” and NetBIOS “corp”. User can login using “us.company.com\username”, but cannot using “corp\username”.
 

環境

  • Tableau Server
  • Active Directory

解決策

Update the nickname used for the new domain.
  • Use tabcmd listdomains to review all domain records in Tableau Server.
  • Use tabcmd editdomain to update any incorrect domain records.
For more information, see tabcmd Commands.

原因

It is currently not possible for Tableau Server to query NetBIOS name of remote domain, and thus Tableau Server has to deduce it. Tableau Server simply uses the latest component of the FQDN (i.e. “us” from “us.company.com”) as a nickname, as this is what Active Directory uses by default when new domain is created.

詳細情報

The following results might also be found in the server logs after attempting to add the user from the new domain:

INFO com.tableausoftware.domain.user.service.InternalUserActions - Site role was updated to Interactor for user <user name> in domain <old domain name> 
INFO com.tableausoftware.domain.user.service.UserManagementService - Auth user Axxxx importing AD user <user name>@<new domain name> (SiteRole: Interactor, IsAdmin: null). 



Discuss this article... Feedback Forum
この記事で問題は解決しましたか?