KNOWLEDGE BASE

Upgrade auf Tableau Server 2018.2 bleibt hängen oder schlägt bei etwa 12 % bzw. 78 % mit aktiviertem SSL fehl


Veröffentlicht: 15 Aug 2018
Zuletzt geändert am: 03 Jan 2019

Problem

Wenn Sie versuchen, ein Upgrade von einer Windows-Installation von Tableau Server 2018.1 oder früher auf Tableau Server 2018.2 durchzuführen, bleibt die Installation bei etwa 12 % oder 78 % hängen oder schlägt fehl.

Umgebung

  • Tableau Server 2018.2 (Upgrade von 2018.1 oder früher)
  • Windows
  • SSL

Lösung

Option 1: 

 Upgrade von Tableau Server auf 2018.2.1



Option 2: 

Wenn Sie kein Upgrade von Tableau Server auf Version 2018.2.1 durchführen können, verwenden Sie folgende Problemumgehung. 

 

Schritt 1: Deaktivieren von SSL vor dem Upgrade
  1. Öffnen Sie als Administrator eine Eingabeaufforderung.
  2. Geben Sie den folgenden Befehl ein, um den Upgrade-Auftrag anzuhalten, falls er noch ausgeführt wird:
    c:\Program Files\Tableau\Tableau Server\packages\scripts.20182.18.0627.2230\stop-administrative-services.cmd
  3. Geben Sie den folgenden Befehl ein, um administrative Dienste zu starten:
    c:\Program Files\Tableau\Tableau Server\packages\scripts.20182.18.0627.2230\start-administrative-services.cmd
  4. Deaktivieren Sie SSL für Gateway und Postgres und wenden Sie ausstehende Änderungen an:

    tsm configuration set -k pgsql.ssl.enabled -v false
    tsm configuration set -k ssl.enabled -v false
    tsm configuration set -k pgsql.ssl.required -v false
    tsm pending-changes apply

Schritt 2: Durchführen des Upgrades
Führen Sie das Upgrade-Skript erneut aus:
c:\Program Files\Tableau\Tableau Server\packages\scripts.20182.18.0627.2230\upgrade-tsm.cmd
Schritt 3: Erneutes Aktivieren von SSL
Führen Sie folgende Schritte nach einem erfolgreichen Upgrade durch:
  1. Auf Wunsch können Sie externes SSL (Gateway-SSL) mithilfe der TSM-CLI erneut anwenden.
  2. Auf Wunsch können Sie Postgres-SSL mithilfe der TSM-CLI erneut anwenden.
  3. Starten Sie Tableau Server mit folgendem Befehl: tsm start

Ursache

Wenn SSL vor dem Upgrade auf Tableau Server 2018.2 aktiviert ist, schlägt das Upgrade-tsm-Skript fehl und der folgende Fehler wird in control_tabsvc_node1-0.log gemeldet:

ERROR com.tableausoftware.service.helpers.JavaTrustStoreDeployer - Failed to import certificates.
java.lang.NullPointerException (FEHLER com.tableausoftware.service.helpers.JavaTrustStoreDeployer – Zertifikate konnten nicht importiert werden. java.lang.NullPointerException)

Zusätzliche Informationen

Dieses Verhalten bezieht sich auf ein bekanntes Problem mit der ID 808909, das in Tableau Server 2018.2.1 behoben wurde.
Hat dieser Artikel das Problem gelöst?