KNOWLEDGE BASE

When Connecting Some CSV Files Encoded With Shift-JIS, Error "Text file has no lines" and "Error Code: 38348B38" is Displayed


Published: 14 Nov 2023
Last Modified Date: 22 Feb 2024

Issue

When connecting some CSV files encoded with Shift-JIS, the following error message is displayed:

An error occurred while communicating with the data source Unable to connect to the file "[xxx.csv]". Check that the file exists and that you have sufficient access privileges for it. Error Code: 38348B38 Text file has no lines.

Environment

  • Tableau Desktop 2022.2 and above
  • Tableau Prep Builder 2022.2 and above

Resolution

Change the encoding of the CSV file from SJIS to UTF-8.

Use a standard editor like NotePad (Windows) or TextEdit (Mac) to update the encoding of the CSV file.

NotePad (Windows)

  1. Open your CSV file in Notepad.
  2. Click File in the top-left corner of your screen.
  3. Click Save as...
  4. In the dialog which appears, select the following options:
    • In the "Save as type" drop-down, select All Files.
    • In the "Encoding" drop-down, select UTF-8.
    • Rename your file using the .csv extension (Example: myproject.csv).
  5. Click Save.

TextEdit (Mac)

TextEdit is the free text editor included in all versions of MacOS.

  1. If your file is not already a CSV, ensure it is in Plain Text (Edit > Make Plain Text)
  2. Go to File > Save 
  3. Give the file a name and use .CSV as the extension
  4. select Unicode (UTF-8) as the encoding option.
  5. Click Save.

 

Cause

Coding needs to be UTF-8.
Did this article resolve the issue?