知識庫

Error "An item with the same key has already been added Key" Occurs When migrating one workbook and one published data source by CMT


發佈時間 : 18 Nov 2022
上次修改日期 : 21 Nov 2022

問題

When you try to migrate one workbook and one published data source by CMT 2022.2.1, the following error might occur:

An item with the same key has already been added Key: Sheet 1


The migration of the workbooks and the data sources are successful after receiving the error but the following issues remains.

1. Post migration script will not run
User-added image

2. Extracts won't be refreshed

User-added image

 

環境

  • Tableau Cloud 2022.3.0
  • CMT 2022.2.1

解決方法

The workaround is deleting workbooks with multiple views with the same name in the destination server.

Error occurs when there are workbooks with multiple views with the same name exist on the destination server.
Ideally, a workbook will never have views with the same name. The multiple views issue can occur in test servers or when content doesn't get deleted properly.

<Example: workbooks with multiple views with the same name>
User-added image

原因

This is a known issue that is being addressed by the development team.

其他資訊


 
這篇文章是否解決了問題?