기술 자료

Error "An item with the same key has already been added Key" Occurs When migrating one workbook and one published data source by CMT


게시 날짜: 18 Nov 2022
마지막 수정 날짜: 21 Nov 2022

문제

When you try to migrate one workbook and one published data source by CMT 2022.2.1, the following error might occur:

An item with the same key has already been added Key: Sheet 1


The migration of the workbooks and the data sources are successful after receiving the error but the following issues remains.

1. Post migration script will not run
User-added image

2. Extracts won't be refreshed

User-added image

 

환경

  • Tableau Cloud 2022.3.0
  • CMT 2022.2.1

해결 방법

The workaround is deleting workbooks with multiple views with the same name in the destination server.

Error occurs when there are workbooks with multiple views with the same name exist on the destination server.
Ideally, a workbook will never have views with the same name. The multiple views issue can occur in test servers or when content doesn't get deleted properly.

<Example: workbooks with multiple views with the same name>
User-added image

원인

This is a known issue that is being addressed by the development team.

추가 정보


 
이 문서로 문제가 해결되었습니까?