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Error "An item with the same key has already been added Key" Occurs When migrating one workbook and one published data source by CMT


発行: 18 Nov 2022
最終修正日: 21 Nov 2022

問題

When you try to migrate one workbook and one published data source by CMT 2022.2.1, the following error might occur:

An item with the same key has already been added Key: Sheet 1


The migration of the workbooks and the data sources are successful after receiving the error but the following issues remains.

1. Post migration script will not run
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2. Extracts won't be refreshed

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環境

  • Tableau Cloud 2022.3.0
  • CMT 2022.2.1

解決策

The workaround is deleting workbooks with multiple views with the same name in the destination server.

Error occurs when there are workbooks with multiple views with the same name exist on the destination server.
Ideally, a workbook will never have views with the same name. The multiple views issue can occur in test servers or when content doesn't get deleted properly.

<Example: workbooks with multiple views with the same name>
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原因

This is a known issue that is being addressed by the development team.

詳細情報


 
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