ナレッジベース

Tableau エラー "エラー コード: 06DA155A [Microsoft][ODBC Driver 17 for SQL Server]クライアントが接続を確立できません..." Azure Synapse Analytics への接続


発行: 28 Oct 2022
最終修正日: 13 Apr 2023

問題

次の TCP 関連のエラーのために Azure Synapse Analytics サーバーに接続できません。

An error occurred while communicating with Azure Synapse Analytics (Azure Synapse Analytics との通信中にエラーが発生しました)
サーバーに接続できません。サーバーが実行されており、要求したデータベースに対してアクセス権限を持っていることを確認してください。
エラー コード: 06DA155A
[Microsoft][ODBC Driver 17 for SQL Server]Client unable to establish connection because an error was encountered during handshakes before login. (ログイン前のハンドシェイク中にエラーが発生したため、クライアントが接続を確立できません。)Common causes include client attempting to connect to an unsupported version of SQL Server, server too busy to accept new connections or a resource limitation (memory or maximum allowed connections) on the server. (一般的な原因には、クライアントがサポートされていないバージョンの SQL Server に接続しようとしている、サーバーがビジー状態にあり新しい接続を受け付けることができない、またはサーバー上のリソース制限 (メモリまたは許可されている最大接続数) が含まれます。)
[Microsoft][ODBC Driver 17 for SQL Server]TCP プロバイダー: 接続先が一定期間後に正しく応答しなかったため、接続に失敗しました。または、接続先のホストが応答に失敗したため、確立された接続に障害が発生しました。
[Microsoft][ODBC Driver 17 for SQL Server]クライアントが接続を確立できません
[Microsoft][ODBC Driver 17 for SQL Server]Client unable to establish connection due to prelogin failure (ログイン前のエラーのため、クライアントが接続を確立できません)
Unable to connect to the Azure Synapse Analytics server "<server name or ip address>". (Azure Synapse Analytics サーバー "<サーバー名または IP アドレス>" に接続できません。)サーバーが実行されており、要求したデータベースに対してアクセス権限を持っていることを確認してください。

環境

  • Tableau Desktop
  • Tableau Server
  • Azure Synapse Analytics

解決策

IT ネットワーク チームと協力して、Azure Synapse Analytics サーバーにアクセスするようにネットワーク設定を構成します。
SQL Azure Database/Azure Synapse Analytics サービスは TCP ポート 1433 でしか使用できないため、ファイアウォールで TCP ポート 1433 上の送信 TCP 通信が許可されていることを確認してください。 
トラブルシューティング情報の詳細については、Microsoft のドキュメント「Azure SQL Database と Azure Synapse の IP ファイアウォール規則 - データベース ファイアウォールのトラブルシューティング」を参照してください。
 

原因

環境 - ネットワーク
"TCP" エラーは、Tableau Desktop または Tableau Server と Azure Synapse Analytics サーバーの間にネットワーク接続の問題があることを示します。

詳細情報

Tableau の側から Azure Synapse Analytics サーバーにアクセスする場合のネットワークの問題があるかどうかを確認するための簡単な方法があります。Excel を使用して Tableau Desktop クライアント PC から Azure Synapse Analytics サーバーに接続してみて、接続が正常に機能するかどうかを確認します。詳細については、Microsoft のドキュメント
Azure SQL Database または Azure SQL Managed Instance 内のデータベースに Excel を接続し、レポートを作成する
」を参照してください
この記事で問題は解決しましたか?