知识库

错误 0x80070643:在 Tableau Server 节点上安装或卸载 RMT 代理版本 2022.1 时,无法执行 MSI 软件包


发布时间: 14 Apr 2022
上次修改日期: 30 Jun 2022

问题

在 Tableau Server 节点上安装、升级或卸载 Tableau RMT代理版本 2022.1 时,会出现以下错误消息: 

RMT 代理 2022.1 安装/卸载失败的错误消息

在此安装失败的日志中,会出现以下错误: 

[2418:2414][2022-04-12T21:08:50]e000: Error 0x80070643: Failed to uninstall MSI package.
[2418:2414][2022-04-12T21:08:50]e000: Error 0x80070643: Failed to execute MSI package.
[20E8:0D58][2022-04-12T21:08:50]e000: Error 0x80070643: Failed to configure per-machine MSI package.
[20E8:0D58][2022-04-12T21:08:50]i319: Applied execute package: SERVER, result: 0x80070643, restart: None
[20E8:0D58][2022-04-12T21:08:50]e000: Error 0x80070643: Failed to execute MSI package.
当用户应用以下文档中的解决方法时,问题没有得到解决。以下文档中的解决方法是更新 GPO 策略,但是这并不能解决所看到的问题:
安装 RMT 工具时出现致命错误
    

环境

  • Tableau Server 2021.X
  • Windows Server
  • Tableau Resource Monitoring Tool 代理版本 2022.1 (20221.22.217.2341)

解决方案

此问题的解决方法是使用 Microsoft Windows Troubleshooter 完全卸载 Tableau RMT 代理,然后在计算机上重新安装 Tableau RMT 代理。以下步骤将有助于此过程: 

1.下载 Microsoft Windows Troubleshooter: 

Microsoft 支持 - 修复阻止程序安装或删除的问题

用户添加的图像

2.  在受影响的计算机上运行下载的“MicrosoftProgram_Install_and_Uninstall.meta.diagcab”程序。单击“下一步”继续。 
用户添加的图像

3.  然后,该程序将检测任何问题,并提供选项来排除安装或卸载方面的故障。选择“卸载”
用户添加的图像

4.  在提供的列表中搜索 Tableau Resource Monitoring Tool 代理程序。选择并单击“下一步”。
用户添加的图像

5. Troubleshooter 将完成,并允许从“Windows 添加或删除程序”中卸载该程序。 
用户添加的图像

6. 卸载 Tableau Resource Monitoring Tool
用户添加的图像

7.卸载 RMT 代理后,可以再次运行 RMT 代理安装程序。这应该允许 RMT 代理完全成功安装。 

原因

开发团队正在解决这个问题。
此文章是否已解决问题?