KNOWLEDGE BASE

Fehler 0x80070643: MSI-Paket konnte bei der Installation oder Deinstallation von RMT Agent Version 2022.1 auf Tableau Server-Knoten nicht ausgeführt werden


Veröffentlicht: 14 Apr 2022
Zuletzt geändert am: 30 Jun 2022

Problem

Beim Installieren, Aktualisieren oder Deinstallieren von Tableau RMT Agent Version 2022.1 auf Tableau Server-Knoten wird die folgende Fehlermeldung angezeigt: 

Error message for RMT Agent 2022.1 failed install/uninstall (Fehlermeldung für RMT Agent 2022.1 - fehlgeschlagene Installation/Deinstallation)

Die Protokolle für diese fehlgeschlagene Installation enthalten die folgenden Fehler: 

[2418:2414][2022-04-12T21:08:50]e000: Error 0x80070643: Failed to uninstall MSI package. (MSI-Paket konnte nicht deinstalliert werden.)
[2418:2414][2022-04-12T21:08:50]e000: Error 0x80070643: Failed to execute MSI package. (MSI-Paket konnte nicht ausgeführt werden.)
[20E8:0D58][2022-04-12T21:08:50]e000: Error 0x80070643: Failed to configure per-machine MSI package. (Die Konfiguration des MSI-Pakets pro Computer ist fehlgeschlagen.)
[20E8:0D58][2022-04-12T21:08:50]i319: Applied execute package: SERVER, result: 0x80070643, restart: None (Angewendetes Ausführungspaket: SERVER, Ergebnis: 0x80070643, Neustart: Keiner)
[20E8:0D58][2022-04-12T21:08:50]e000: Error 0x80070643: Failed to execute MSI package. (MSI-Paket konnte nicht ausgeführt werden.)
Wenn der Benutzer die in der folgenden Dokumentation beschriebene Umgehung anwendet, wird das Problem nicht behoben. Die dort beschriebene Umgehung besteht darin, die GPO-Richtlinie zu aktualisieren, was das Problem jedoch nicht behebt:
Fatal error while installing RMT tool (Schwerwiegender Fehler bei der Installation des RMT-Tools)
    

Umgebung

  • Tableau Server 2021.X
  • Windows Server
  • Tableau Resource Monitoring Tool Agent Version 2022.1 (20221.22.217.2341)

Lösung

Die Umgehung dieses Problems besteht darin, den Tableau RMT Agent mithilfe der Microsoft Windows-Problembehandlung komplett zu deinstallieren und anschließend erneut auf dem Computer zu installieren. Die folgenden Schritte helfen Ihnen bei diesem Prozess: 

1. Laden Sie den Microsoft Windows Troubleshooter herunter: 

Microsoft Support: Beheben von Problemen, die eine Installation oder Deinstallation von Programmen blockieren

Vom Benutzer hinzugefügtes Bild

2. Führen Sie das heruntergeladene Programm "MicrosoftProgram_Install_and_Uninstall.meta.diagcab" auf dem betroffenen Computer aus. Klicken Sie auf "Weiter", um fortzufahren. 
Vom Benutzer hinzugefügtes Bild

3. Das Programm sucht dann nach Problemen und bietet eine Auswahl zur Problembehebung bei Installationen oder Deinstallationen. Wählen Sie "Deinstallation" aus.
Vom Benutzer hinzugefügtes Bild

4. Suchen Sie das Tableau-Programm "Resource Monitoring Tool Agent" in der angezeigten Liste. Wählen Sie es aus und klicken Sie auf "Weiter".
Vom Benutzer hinzugefügtes Bild

5. Die Problembehebung wird beendet und ermöglicht die Deinstallation des Programms über die Windows-Funktion "Software". 
Vom Benutzer hinzugefügtes Bild

6. Deinstallieren Sie das Tableau Resource Monitoring Tool.
Vom Benutzer hinzugefügtes Bild

7. Nachdem der RMT-Agent deinstalliert wurde, kann das RMT-Agent-Installationsprogramm erneut ausgeführt werden. Dadurch sollte sich der RMT-Agent vollständig und erfolgreich installieren lassen. 

Ursache

Dieses Problem wird derzeit vom Entwicklungsteam bearbeitet.
Hat dieser Artikel das Problem gelöst?