知识库

Tableau Desktop 上没有通过产品密钥激活的选项


发布时间: 05 Apr 2022
上次修改日期: 11 Oct 2023

问题

在激活 Tableau Desktop 时,用户看不到使用产品密钥进行激活的选项。只有一个选项(通过登录到服务器激活)可用。

环境

  • Tableau Desktop
  • Windows
  • Mac

解决方案

请咨询 Tableau Server 管理员或公司 IT 团队,以确保 LBLM 不是在 Tableau 环境中使用的理想激活方法。默认设置是在 Tableau 中同时显示 LBLM 和产品密钥激活选项。  如果只显示 LBLM 激活选项,则表示 Tableau 配置为使用 LBLM 作为唯一的激活方法。  以下步骤将更新此设置,使其包括两种激活方法(产品密钥和服务器登录):

1.关闭所有正在运行的 Tableau Desktop 实例。

2.在运行 Tableau Desktop 的计算机上,以管理员身份编辑注册表,在 HKEY_LOCAL_MACHINE\SOFTWARE\Tableau 中找到名为 ATR 的 Hive,并将 LBLM 值从必需修改为已启用

3.如果使用 Mac 操作系统,请按如下方式编辑 plist 文件:sudo defaults write /Library/Preferences/com.tableau.ATR LBLM "enabled"

通过编辑注册表更改 Tableau Desktop 上的基于登录的许可证管理设置

注意:如果设置为“已启用”,许可屏幕将显示两个激活选项(产品密钥或凭据)。

4.重新启动 Tableau Desktop,用户应该看到两个激活选项——使用产品密钥激活和通过登录到服务器激活

原因

在 Windows 注册表或 MAC plist 文件中,LBLM 值设置为“必需”。  出现许可屏幕时,它将只提供凭据激活选项。  通过命令行或通过更新 Windows 注册表或 Mac plist 文件更改安装默认选项时,可能出现将 LBLM 作为唯一激活方法的情况。

 
此文章是否已解决问题?