KNOWLEDGE BASE

Keine Option zur Aktivierung mit einem Produktschlüssel in Tableau Desktop


Veröffentlicht: 05 Apr 2022
Zuletzt geändert am: 11 Oct 2023

Problem

Bei der Aktivierung von Tableau Desktop wird den Benutzern keine Option zur Aktivierung mit einem Produktschlüssel angezeigt. Es ist nur eine Option ("Aktivieren durch Anmeldung am Server") verfügbar.

Umgebung

  • Tableau Desktop
  • Windows
  • Mac

Lösung

Wenden Sie sich an Ihren Tableau Server-Administrator oder das IT-Team Ihres Unternehmens, um sicherzustellen, dass LBLM NICHT die gewünschte Aktivierungsmethode in der Tableau-Umgebung ist. Standardmäßig werden in Tableau sowohl die LBLM- als auch die Produktschlüssel-Aktivierungsoptionen angezeigt.  Wenn nur die LBLM-Aktivierungsoption angezeigt wird, dann wurde Tableau so konfiguriert, dass ausschließlich LBLM als Aktivierungsmethode verwendet wird.  Mit den folgenden Schritten aktualisieren Sie diese Einstellung, um beide Aktivierungsmethoden (Produktschlüssel und Serveranmeldung) zu berücksichtigen:

1. Schließen Sie alle Tableau Desktop-Instanzen, die aktuell ausgeführt werden.

2. Bearbeiten Sie als Administrator auf dem Computer, auf dem Tableau Desktop ausgeführt wird, die Registrierung und suchen Sie unter HKEY_LOCAL_MACHINE\SOFTWARE\Tableau den Hive namens ATR und ändern Sie den LBLM-Wert von required (erforderlich) auf enabled (aktiviert).

3. Wenn Sie ein Mac-Betriebssystem verwenden, bearbeiten Sie die plist-Datei wie folgt: sudo defaults write /Library/Preferences/com.tableau.ATR LBLM "enabled"

Ändern der Einstellungen für die Login-basierte Lizenzverwaltung auf Tableau Desktop durch Bearbeiten der Registrierung

Hinweis: Wenn Sie diese Option aktivieren, werden auf den Lizenzierungsbildschirmen zwei Optionen für die Aktivierung angezeigt (Produktschlüssel oder Anmeldeinformationen).

4. Starten Sie Tableau Desktop neu. Die Benutzer sollten beide Aktivierungsoptionen sehen – "Aktivieren mit einem Produktschlüssel" und "Aktivieren durch Anmeldung bei einem Server"

Ursache

In der Windows-Registrierung oder in einer MAC plist-Datei ist der LBLM-Wert auf "required" (erforderlich) gesetzt.  Wenn der Lizenzierungsbildschirm angezeigt wird, bietet er nur die Anmeldedatenoption für die Aktivierung an.  LBLM kann die einzige Aktivierungsmethode sein, wenn die Standardoptionen für die Installation entweder über die Befehlszeile oder durch eine Aktualisierung der Windows-Registrierung oder der Mac plist-Datei geändert wurden.

 
Hat dieser Artikel das Problem gelöst?