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Tableau Desktop kann keine Verbindung zu veröffentlichten Datenquellen auf Tableau Server herstellen mit Fehlercode: 1076C501 und Meldung: HTTP Status 405 – Method Not Allowed (HTTP-Status 405 - Methode nicht zulässig)


Veröffentlicht: 14 Oct 2021
Zuletzt geändert am: 09 Dec 2022

Problem

Der folgende Fehler kann in Tableau Desktop auftreten, wenn Sie versuchen, eine Verbindung zu einer auf Tableau Server veröffentlichten Datenquelle herzustellen:

An error occurred while communicating with Tableau Server. (Bei der Kommunikation mit Tableau Server ist ein Fehler aufgetreten.)
Bad Connection: Tableau could not connect to the data source. (Ungültige Verbindung: Tableau konnte keine Verbindung zur Datenquelle herstellen.)
Error Code (Fehlercode): 
1076C501
Error: Unable to connect to this Tableau Server data source. (Fehler: Keine Verbindung zu dieser Tableau Server-Datenquelle möglich.)
HTTP 405: <!doctype html><html lang="en"><head><title>HTTP Status 405 – Method Not Allowed</title><style type="text/css">body {font-family:Tahoma,Arial,sans-serif;} h1, h2, h3, b {color:white;background-color:#525D76;} h1 {font-size:22px;} h2 {font-size:16px;} h3 {font-size:14px;} p {font-size:12px;} a {color:black;} .line {height:1px;background-color:#525D76;border:none;}</style></head><body><h1>HTTP Status 405 – Method Not Allowed</h1></body></html>
There was an error with the data source "xxxx". (Bei der Datenquelle "xxxx" ist ein Fehler aufgetreten.) Verify that the data source is configured correctly. (Überprüfen Sie, ob die Datenquelle ordnungsgemäß konfiguriert ist.)

 

Umgebung

  • Tableau Server
  • Tableau Desktop
  • Windows Server 
  • Proxyserver
  • F5-Lastausgleich

Lösung

1. Wenn ein externer Lastausgleich wie F5 verwendet wird, wenden Sie sich an den Netzwerkadministrator, um die HTTP-Profileinstellung in F5 zu überprüfen und zu ändern. 

2. Führen Sie andernfalls die folgenden TSM-Befehle auf Tableau Server aus. Wenn Tableau Server in einer verteilten Umgebung ausgeführt wird, führen Sie die Befehle auf dem ersten Knoten des Clusters aus und prüfen Sie die Ergebnisse:
  • tsm configuration get -k gateway.trusted
  • tsm configuration get -k gateway.public.host
  • tsm configuration get -k gateway.public.port
Die Ergebnisse der obigen Befehle müssen mit den entsprechenden tsm-Konfigurationsoptionen übereinstimmen, die in der Tableau-Hilfedokumentation Konfigurieren von Proxys für Tableau Server beschrieben sind.

Ursache

Tableau Server wurde nicht ordnungsgemäß für die Zusammenarbeit mit einem Proxyserver und/oder Lastausgleich konfiguriert.
Oder:
Das HTTP-Profil für den F5-Lastausgleich wurde nicht korrekt konfiguriert.
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