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LBLM Activation Fails with error "The Tableau license server at https://atr.licensing.tableau.com:443/ returned an error"


Date de publication : 30 Jul 2021
Date de dernière modification : 10 Apr 2024

Problème

When trying to activate Tableau Desktop or Tableau Prep Builder using Login-based License Management (LBLM), the following error may occur:
 

Unable to activate by signing in. The Tableau license server at https://atr.licensing.tableau.com/443 returned an error. If the issue persists contact Tableau Support.

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Environnement

  • Tableau Desktop
  • Tableau Server 2021.1 and newer

Résolution

Option 1

Check Tableau Server connectivity to the ATR licensing server.

Paste the following URL into a browser or at a curl command prompt on the Tableau Server computer:
https://atr.licensing.tableau.com/_status/healthz

If Tableau Server is able to access the licensing server, an "OK" message displays. Otherwise, an error such as "Can't reach this page" may be displayed.

To resolve this issue, work with your networking team to unblock access to atr.licensing.tableau.com:443 on the Tableau Server computer as well as the other URLs noted in the Communicating with the Internet guide.

Option 2

The proxy server or Run as Service account is not configured correctly.

Configure the forward proxy server on Tableau Server as described in the Tableau Online Help guide.

Note:  The proxy server needs to be configured for the Tableau Server run as service account: Run As Service Account.   It is not possible to configure the proxy for the NT AUTHORITY\NetworkService account, hence Tableau must be configured for the Run As Service Account.  Using the Run as Service account allows the proxy to be configured in the LAN settings.

Check Forward proxy configuration in this detailed way:
  1. Check the run as user permission:
    1. Go to Tableau Server folder, Right click and go to "Properties" - "Security".User-added image
    2. Check if the TSM "Run as User account" user appears in "Group or user names" as the above image or not. Make sure the user name exactly matches here and TSM Run as User account user name. e.g. EC2AMAZ\Administrator. If not, add this user name by clicking Edit > Add.
    3. Check if this user name has Full control permission. If not, allow it.
    4. if "LOCAL SERVICE" and "NETWORK SERVICE" are not there or don't have the "Full control". Add them in.
  2. Check System environment variables setting:
    1. Use Windows search bar and input "Edit the System Environment Variables" then go to Environment Variables.
    2. If http_proxy and https_proxy is not under System variables, create them. e.g. the forward proxy IP is 192.168.1.200:8080, then set http_proxy value as http://192.168.1.200:8080 and https_proxy value as http://192.168.1.200:8080.User-added image
  3. Restart the Windows server to allow the permission and environment variables change is effective.
  4. After restart and Tableau Server services are all up and running, go to TSM and configure the correct Run as user account user name and password and  then save the pending changes and restart Tableau Server services.
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  5. Now test LBLM activation again.
  6. After you have tested the proxy settings, remove the Run As service account from the Local Administrators group. Leaving the Run As service account in the administrator group elevates the permissions of the Run As service account and is a security risk. Restart Tableau Server to ensure that all changes are implemented

Cause

The Tableau Server is not able to reach the ATR Licensing service due to a forward proxy or network issue.
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