BASE DE CONOCIMIENTO

Errores "Cannot connect to Tableau Server", "Error Code: 9F4C5638" e "Internet Communication error" al conectarse a Tableau Server o publicar en él


Publicado: 02 Jun 2021
Fecha de la última modificación: 19 Jun 2023

Problema

Cuando sea posible conectarse a Tableau Server desde un navegador de Internet, puede que se produzca el siguiente error al conectarse a Tableau Server desde Tableau Desktop o al publicar contenido en Tableau Server:

Unable to complete action (No se pudo completar la acción)
Cannot connect to Tableau Server (No se puede conectar a Tableau Server). Please check the server name and port and try again. (No es posible conectarse a Tableau Server. Compruebe el nombre y el puerto del servidor e intente nuevamente).
Error Code: 9F4C5638 (Código de error: 9F4C5638)
Internet communication error: Couldn't connect to server (
<server address>) [Error de comunicación de Internet: no fue posible conectarse al servidor (<dirección del servidor>)].
O bien 
Internet communication error: SSL peer certificate or SSH remote key was not OK (hostname.url.com) [Error de comunicación de Internet: el certificado de pares SSL o la clave remota SSH no era correcto (nombredelhost.url.com)].
O bien
Internet communication error: Couldn't resolve host name (servername) [Error de comunicación de Internet: no se pudo resolver el nombre de host (nombre de servidor)].

Entorno

  • Tableau Desktop en Windows
  • Tableau Server

Solución

Opción 1 

Si se utiliza un proxy, la siguiente opción necesitará la participación del equipo de TI en su organización:

Para la excepción del proxy, asegúrese de que solo se introduzca el nombre de Tableau Server en la lista de direcciones de excepción.

Por ejemplo, en lugar de:
https://tableau.mycompany.com 

introduzca:
tableau.mycompany.com

Opción 2

Un problema con la clave de producto activada en Tableau Desktop generó este problema para algunos de nuestros usuarios que no son de LBLM.
  1. Abra Tableau Desktop > Ayuda > Administrar claves de productos > Seleccione su licencia > Actualizar > Cerrar.
  2. Reinicie Tableau Desktop.
  3. Realice una publicación o inicie sesión en Server.

Opción 3

Compruebe si hay otras CA raíz en los archivos de certificado en Windows y verifique con su administrador de red qué certificados son los de CA raíz requeridos. Puede que se necesite Wireshark o un seguimiento similar para comprobar qué certificado se ve afectado o cuál falta en Intermediary o RootCA. 

Puede encontrarse un error en el archivo de registro de Tableau Desktop (log.txt) como "CryptoAPI nonfatal certificate verification error: '/C=US/ST=California/L=XXXXX/O=XXXXX/CN=hostname.url.com' error code 1000040"}".

Opción 4

Trabaje con el equipo de red para investigar y corregir el nombre de servidor de DNS especificado en Tableau Desktop. Para ello, realice una búsqueda inversa de DNS en Tableau Server.  Cuando el DNS no es correcto, se produce el siguiente error en la búsqueda inversa: ** server can't find IP ADDRESS.in-addr.arpa: NXDOMAIN.   

El NXDOMAIN es un tipo de mensaje DNS que recibe el agente de resolución DNS (es decir, el cliente) cuando se envía una solicitud de resolución de nombres de dominio y no se logra determinar la dirección IP. Un mensaje de error NXDOMAIN significa que el dominio no existe.

Causa

Existen varios motivos de este error general de comunicación de Internet.  Las siguientes son algunos de las causas raíz:
  • Tableau Desktop no admite la inclusión del protocolo en los valores introducidos al configurar las excepciones de proxy.  
  • Se cargó un nuevo certificado SSL.
  • Se necesita una clave de producto de Desktop para la actualización.
  • Se encontró el mismo certificado Root CA en Intermediate Store y en Root CA Store.
  • No se pudo resolver el DNS en una dirección IP a pesar de que se especificó de forma correcta en el certificado SSL.
¿Fue de ayuda este artículo para resolver el problema?