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Fehler "Cannot connect to Tableau Server" (Verbindung zu Tableau Server nicht möglich), "Error Code (Fehlercode): 9F4C5638" und "Internet Communication error" (Internetkommunikationsfehler) beim Verbinden mit oder Veröffentlichen auf Tableau Server


Veröffentlicht: 02 Jun 2021
Zuletzt geändert am: 19 Jun 2023

Problem

Es ist zwar möglich, eine Verbindung zu Tableau Server von einem Internetbrowser aufzubauen, jedoch kann beim Verbinden mit Tableau Server von Tableau Desktop oder beim Veröffentlichen von Inhalten an Tableau Server der folgende Fehler auftreten:

Unable to complete action (Aktion kann nicht ausgeführt werden)
Cannot connect to Tableau Server. Please check the server name and port and try again. (Es kann keine Verbindung zu Tableau Server hergestellt werden. Überprüfen Sie den Servernamen und den Port und versuchen Sie es erneut.)
Error Code (Fehlercode): 9F4C5638
Internet communication error: Couldn't connect to server (
<server address>). (Internetkommunikationsfehler: Verbindung mit Server (<Server-Adresse>) konnte nicht hergestellt werden.)
oder 
Internet communication error: SSL per certificate or SSH remote key was not OK (hostname.url.com). (Internet-Kommunikationsfehler: SSL-Peer-Zertifikat oder SSH-Remoteschlüssel war nicht OK (hostname.url.com).)
oder
Internet communication error: Couldn't resolve host name (servername) (Fehler bei der Internetkommunikation: Hostname (Servername) konnte nicht aufgelöst werden.)

Umgebung

  • Tableau Desktop unter Windows
  • Tableau Server

Lösung

Option 1 

Beim Verwenden eines Proxy ist für die folgende Option die Zusammenarbeit mit dem IT-Team in Ihrer Organisation erforderlich:

Stellen Sie für die Proxy-Ausnahme sicher, dass nur der Tableau Server-Name in die Liste der Ausnahmeadressen eingegeben wird.

Geben Sie zum Beispiel anstelle von:
https://tableau.mycompany.com 

Folgendes ein:
tableau.mycompany.com

Option 2

Ein Problem mit dem Produktschlüssel, der auf Tableau Desktop aktiviert wurde, hat dieses Problem für einige unserer Nicht-LBLM-Benutzer verursacht.
  1. Öffnen Sie Tableau Desktop > "Hilfe" > "Produktschlüssel verwalten" > Wählen Sie Ihre Lizenz aus > "Aktualisieren" > "Schließen"
  2. Starten Sie Tableau Desktop neu.
  3. Veröffentlichen Sie auf dem Server oder melden Sie sich beim Server an.

Option 3

Überprüfen Sie, ob in den Zertifikatsdateien von Windows zusätzliche Stamm-CAs gefunden wurden, und klären Sie mit Ihrem Netzwerkadministrator, welche Zertifikate die erforderlichen Stamm-CAs sind. Möglicherweise ist ein Wireshark oder ähnlicher Trace erforderlich, um zu verifizieren, welches Zertifikat für den Vermittler oder RootCA betroffen ist oder fehlt. 

In der Tableau Desktop-Protokolldatei (log.txt) kann ein Fehler wie der folgende gefunden werden: "CryptoAPI nonfatal certificate verification error: '/C=US/ST=California/L=XXXXX/O=XXXXX/CN=hostname.url.com' error code 1000040"}" (CryptoAPI nicht schwerwiegender Fehler bei Zertifikatsverifizierung: '/C=US/ST=California/L=XXXXX/O=XXXXX/CN=hostname.url.com' Fehlercode 1000040"})

Option 4

Untersuchen und korrigieren Sie gemeinsam mit dem Netzwerk-Team den DNS-Servernamen, der auf Tableau Desktop angegeben ist, indem Sie einen Reverse-DNS-Lookup des Tableau Servers ausführen.  Wenn der DNS nicht korrekt ist, wird beim Reverse-Lookup folgender Fehler auftreten: ** server can't find IP ADDRESS.in-addr.arpa: NXDOMAIN (** Server konnte IP ADDRESS.in-addr.arpa: NXDOMAIN nicht finden).

NXDOMAIN ist ein DNS-Nachrichtentyp, den der DNS-Resolver (d. h. der Client) erhält, wenn eine Anforderung zur Auflösung einer Domäne an den DNS gesendet wird und nicht in eine IP-Adresse aufgelöst werden kann. Eine NXDOMAIN-Fehlermeldung bedeutet, dass die Domäne nicht existiert.

Ursache

Es gibt mehrere Ursachen für diesen allgemeinen Internet-Kommunikationsfehler.  Hier sind einige der Hauptursachen:
  • Tableau Desktop unterstützt nicht die Einbeziehung des Protokolls in Werte, die bei der Konfiguration von Proxy-Ausnahmen eingegeben werden.  
  • Ein neues SSL-Zertifikat wurde hochgeladen.
  • Desktop-Produktschlüssel musste aktualisiert werden.
  • Dasselbe Root CA-Zertifikat wurde im Zwischenspeicher und im Root CA-Speicher gefunden.
  • DNS konnte nicht in eine IP-Adresse aufgelöst werden, obwohl sie im SSL-Zertifikat korrekt angegeben ist.
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