KNOWLEDGE BASE

Fehler "The custom geocoding folder ... has errors" beim Erstellen der Karte


Veröffentlicht: 27 Jan 2015
Zuletzt geändert am: 11 Oct 2022

Problem

Bei der Erstellung einer Karte in Tableau Desktop treten möglicherweise folgende Fehler auf:
 
The custom geocoding folder C:\Program Files (x86)\Tableau\Tableau 8.3\local\data has errors. 
There was a problem connecting to the data source C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\AreaCode.tds: 
Error encountered while loading C:\Program Files (x86)\Tableau\Tableau 8.3\bin\fbclient.dll 
Unable to connect to the file "C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\GEOCODING.FDB". Check that the file exists and that you have sufficient access privileges for it. (Die benutzerdefinierte Geokodierungsdatenquelle C:\Programme (x86)\Tableau\Tableau 8.3\local\data enthält Fehler: Firebird-Datenbankfehler 335544344: E/A-Fehler beim Vorgang "CreateFile (open)" für Datei "GEOCODING.FDB" -Fehler beim Versuch, die Datei zu öffnen. -Das System kann die angegebene Datei nicht finden. Die Verbindung zur Datei "GEOCODING.FDB" kann nicht hergestellt werden. Stellen Sie sicher, dass die Datei vorhanden ist und dass Sie über ausreichende Zugriffsberechtigungen dafür verfügen.)

The custom geocoding data source C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\City.tds contains errors: 
boost::bad_any_cast: failed conversion using boost::any_cast 
Unable to connect to the file "C:\Program Files (x86)\Tableau\Tableau 8.3\local\data\GEOCODING.FDB". Check that the file exists and that you have sufficient access privileges for it. (Die benutzerdefinierte Geokodierungsdatenquelle C:\Programme (x86)\Tableau\Tableau 8.3\local\data enthält Fehler. Fehlgeschlagene Konvertierung von boost::bad_any_cast: mit boost::any_cast. Die Verbindung zur Datei "C:\Programme (x86)\Tableau\Tableau 8.3\local\data\GEOCODING.FDB" kann nicht hergestellt werden. Stellen Sie sicher, dass die Datei vorhanden ist und dass Sie über ausreichende Zugriffsberechtigungen dafür verfügen.)

Umgebung

Tableau Desktop

Lösung

Option 1

Überprüfen Sie, ob ein Firebird-Ordner im Programmdatenverzeichnis vorhanden ist:
  
 
1. Navigieren Sie zu: C:\Programme.
2. Bestätigen Sie, dass der Ordner "/firebird" vorhanden ist.
  • Bestätigen Sie, dass die Berechtigungen des Ordners auf "Lesen/Schreiben" festgelegt sind.
3. Wenn dieser Ordner nicht vorhanden ist:
  •      Erstellen Sie einen Ordner namens "firebird".
  • Bestätigen Sie, dass die Berechtigungen des Ordners auf "Lesen/Schreiben" festgelegt sind.
 4. Starten Sie Tableau Desktop neu und öffnen Sie die Arbeitsmappe erneut.

Wenn die Kartenerstellung weiterhin nicht funktioniert, nachdem Sie diese Schritte durchgeführt haben, deinstallieren Sie Tableau Desktop und installieren Sie es erneut:
  1. Deinstallieren Sie Tableau Desktop vollständig.
    • Deinstallieren Sie die Anwendung.
    • Löschen Sie den Tableau-Ordner unter folgendem Pfad:C:\Programme oder C:\Programme (x86).
  2. Starten Sie den Computer neu.
  3. Installieren Sie Tableau Desktop neu.

Option 2

  1. Gehen Sie zu Systemsteuerung > Programme und Features > wählen Sie Tableau Desktop aus > klicken Sie auf Deinstallieren/Ändern.
  2. Wählen Sie für die Installationsanwendung Reparieren aus.

Ursache

Während des Installationsvorgangs wurde Firebird nicht ordnungsgemäß installiert. Daher ist die Variable "FIREBIRD_LOCK" festgelegt, die ein ordnungsgemäßes Geokodieren verhindert.
Hat dieser Artikel das Problem gelöst?